Author Topic: Is it possible to remove the "update now" nag screen?  (Read 1259 times)

uptown47

  • Newbie
  • *
  • Posts: 20
Re: Is it possible to remove the "update now" nag screen?
« Reply #7 on: August 20, 2019, 04:49:02 AM »
Quote
So... I'm back with 6.3 which works and is fast but I don't like the nag screen as I just want to boot into my front end without being told that there's an update
Maybe try to edit the mGalaxy/Data/Settings.xml file and change the <Settings version="6.3"> to a later version like "<Settings version="66.3"> !? I think it may work!

That's a great idea!! (if it works!). I'll give that a go and report back. Thanks :)

jmd

  • Full Member
  • ***
  • Posts: 181
    • Email
Re: Is it possible to remove the "update now" nag screen?
« Reply #6 on: August 20, 2019, 04:41:57 AM »
Quote
So... I'm back with 6.3 which works and is fast but I don't like the nag screen as I just want to boot into my front end without being told that there's an update
Maybe try to edit the mGalaxy/Data/Settings.xml file and change the <Settings version="6.3"> to a later version like "<Settings version="66.3"> !? I think it may work!

uptown47

  • Newbie
  • *
  • Posts: 20
Re: Is it possible to remove the "update now" nag screen?
« Reply #5 on: August 20, 2019, 03:42:23 AM »
The folder just unzipped to my desktop and I ran it from there. I didn't put it into the Program Files folder.
Sorry to insist, you're talking of a folder unzipped to the desktop...are you talking of the installer or the mGalaxy folder itself?
So, you're doing a fresh install to the desktop an mGalaxy, running mGalaxy_Runway with no problem...but mGalaxy itself refuses to run?

Hiya, no problem, I'll explain a bit better if I can :)

The series of events was like this... I booted up my fruit machine - which automatically runs mGalaxy (it was running the previous 6.3 version).

The message popped up "There's a new version available do you want to update now".

"Yes"

It then downloaded and I can't remember whether it ran itself or I ran it. However, the mGalaxy_Runway appeared however my Fruit Machine theme wasn't in there because my license had expired.

I tried to run mGalaxy anyway but it displayed the "checking for updates" message and then the new fancy logo appeared in the middle of the screen and it didn't go any further than that. After a few minutes (when I realised it wasn't working) I hit the Windows key to see what was going on behind it and ran Task Manager. It looked like mGalaxy and Chrome were using a lot of resources so I just killed the processes and rebooted my machine.

Upon the reboot I ran mGalaxy again and the same thing happened. It just seemed to lock up.

At that point I decided that it might be because my license had run out so I renewed my license but it took a while to process so I left it until the next day.

My new license arrived and I found the new mGalaxy folder was on my desktop. I therefore sussed that it was a portable installation. I put my License.xml in the folder and then changed the mGalaxy_runway to the Fruit Machine theme.

Still no dice. When I ran mGalaxy it just froze on the splash screen. The colours were still swirling around the logo (not sure if that's just a gif though?).

So, I checked the specs of the program to see if it wasn't Windows 7 compatible but it said it was.

So I just dumped it and went back to v6.3.

I did try a different theme initially (before I got my license) in the new mGalaxy and I did get through to the main screen but none of my buttons would work to scroll the list up and down etc.

The new version seems very resource hungry and all I need is a way of picking a fruit machine from a list with a screenshot so it is probably overkill for what I'm wanting.

So... I'm back with 6.3 which works and is fast but I don't like the nag screen as I just want to boot into my front end without being told that there's an update OR I want to get the latest version running in a way that it doesn't lock the whole machine up.

Hope that helps... if you need more information then just let me know.

Cheers :-)

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 1059
    • Email
Re: Is it possible to remove the "update now" nag screen?
« Reply #4 on: August 20, 2019, 03:17:34 AM »
The folder just unzipped to my desktop and I ran it from there. I didn't put it into the Program Files folder.
Sorry to insist, you're talking of a folder unzipped to the desktop...are you talking of the installer or the mGalaxy folder itself?
So, you're doing a fresh install to the desktop an mGalaxy, running mGalaxy_Runway with no problem...but mGalaxy itself refuses to run?

uptown47

  • Newbie
  • *
  • Posts: 20
Re: Is it possible to remove the "update now" nag screen?
« Reply #3 on: August 20, 2019, 01:42:02 AM »
1. Did you install the new version over the old one?
2. If yes, I remind you that mGalaxy is now portable and CAN'T be installed inside the 'Program Files' folder
3. Could you try to install the new version in a temporary folder (out of the 'Program File' folder)...and report if it works?
Hi there,
Thanks for getting back to me.

The folder just unzipped to my desktop and I ran it from there. I didn't put it into the Program Files folder.

Thanks for your help.

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 1059
    • Email
Re: Is it possible to remove the "update now" nag screen?
« Reply #2 on: August 19, 2019, 04:51:15 PM »
1. Did you install the new version over the old one?
2. If yes, I remind you that mGalaxy is now portable and CAN'T be installed inside the 'Program Files' folder
3. Could you try to install the new version in a temporary folder (out of the 'Program File' folder)...and report if it works?

uptown47

  • Newbie
  • *
  • Posts: 20
Is it possible to remove the "update now" nag screen?
« Reply #1 on: August 19, 2019, 01:35:12 PM »
Hi all,
I use mGalaxy with a fruit machine I built that uses MFME (Multi Fruit Machine Emulator).

A long time ago the developer of mGalaxy kindly made a 'theme' for us MFME users. This has worked brilliantly until my machine asked me to update to the latest version. Which I did. This then just caused my machine to freeze whenever I tried to run mGalaxy.

Tried the usual - uninstall - reinstall etc... I'm running Windows 7 (64 bit) so it should run fine.

Anyhoo... long story short I went back to the previous version 6.3? and this runs fine. I still have to re-set everything up again but I can get that sorted at the weekend. The only thing is that now it keeps nagging me to update whenever it starts?

So... firstly, anyone know why the new version is locking up? Second question - anyone know how to remove the 'please update' nag screen?

Thanks :-)