Author Topic: Speed Issue  (Read 1885 times)

adrinan

  • Newbie
  • *
  • Posts: 3
    • Email
Speed Issue
« on: August 10, 2013, 08:14:40 AM »


I love Mgalaxy - easy to use and i'd like to use it forever on my cabinet - trouble is - it's running really slowly..   especially in the menu's.   

I can't seem to find system specs either - i'm using an old AMD Athlong 64 3200+ with a gig of ram - is it likely that I just don't have enough grunt?

I don't mind upgrading so Mgalaxy works but i'm wondering if that's the issue before I spend the $$ - I would rather save my money if there's a fix and donate it for the great software!

Aeliss

  • Hero Member
  • *****
  • Posts: 676
Re: Speed Issue
« Reply #1 on: August 10, 2013, 11:43:23 AM »
It 's slow when you travel in the game list ? The only slowdown i have are when I select a new emulator, time for mGalaxy to make the game list I think.

My old configuration was the same processor than you, 2 G ram and an old 9800 gts (on Win XP), and I havent noticed something ?

Perhaps it s the graphic card, but it will be strange just to display a list of roms.
You have slowdown on all menu or only if you have screenshoot too ?

adrinan

  • Newbie
  • *
  • Posts: 3
    • Email
Re: Speed Issue
« Reply #2 on: August 10, 2013, 10:49:25 PM »
It's only slow in the screen where you can choose favourites or all.   And turn clones on or off.   Everywhere else seems fine including the game selection screen.   And I have a full mame set with snaps. 

Aeliss

  • Hero Member
  • *****
  • Posts: 676
Re: Speed Issue
« Reply #3 on: August 11, 2013, 05:14:12 AM »
Ok, I had not undestood.

Sorry I haven't ideas for that.

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 828
    • Email
Re: Speed Issue
« Reply #4 on: August 11, 2013, 06:47:36 PM »
It's not the display of the menu which (you see as) is slow...but the operation you're doing there.
Filtering on "Favorite" or "Clone" or anything else actually rebuild the entire list.
The 19.000 roms of your mame set is scanned again.
It then verify (for each rom!!!) that
- you own this rom
- that this rom belongs to the favorite list or not
- that this is a clone or not
- that there's a filter on 'mature', 'pinball', 'bios', etc...to be applied or not
- that there's a filter on the genre to be applied or not
- that there's a filter on the numbers of players to be applied or not

...19.000 times, to finally display the result in a new list!
The same procedure is accomplished when mGalaxy launch...so you perhaps don't "see" it, but it take the same time at the mGalaxy opening!
Opening the filter menu isn't slower than filtering roms at launch time.

This procedure has been optimized since the early beginning of the mGalaxy development
On my i7 this is nearly instantaneous, on my Pentium IV arcade cabinet it takes about 2 secs.

I don't know why it it take so much time!? How much actually??
I've seen some performance breakdown with...slow hard drives, which doesn't deliver the rom list quickly enough to mGalaxy.
« Last Edit: August 11, 2013, 06:50:45 PM by mgalaxy »

davhuit

  • Full Member
  • ***
  • Posts: 173
Re: Speed Issue
« Reply #5 on: August 12, 2013, 10:52:22 AM »
I don't have this problem because I don't have so much roms, but maybe adding an option which would disable the first-run scan might solve this sort of problem? (and when you would reactivate it, "mGalaxy" would rescan the roms during the next startup).

A bit like some emulators which have a "scan now" option.

Just some thoughts ^^