Author Topic: illegal boolean value for sound reverting to 0  (Read 187 times)

razoba

  • Newbie
  • *
  • Posts: 3
    • Email
illegal boolean value for sound reverting to 0
« on: October 13, 2019, 09:01:41 AM »
Setup mame emulator on mgalaxy and im getting this error message when loading up a game

illegal boolean value for sound reverting to 0

the pc is connected via hdmi to tv, sound through tv

the games load fine when running  directly through mame

Any thoughts on how to resolve

thanks

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 979
    • Email
Re: illegal boolean value for sound reverting to 0
« Reply #1 on: October 15, 2019, 02:29:13 AM »
Which Mame version are you using?

razoba

  • Newbie
  • *
  • Posts: 3
    • Email
Re: illegal boolean value for sound reverting to 0
« Reply #2 on: October 15, 2019, 01:37:19 PM »
MameUI64.135 is the executable

so im thinking its 0.135

seems a very old version, im guessing it was the one i could get to work with my set of roms


mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 979
    • Email
Re: illegal boolean value for sound reverting to 0
« Reply #3 on: October 15, 2019, 02:09:30 PM »
Yes indeed, this is a 10 years old version ;)
The command line used by mGalaxy to run the games may be incompatible with this .135 version
Would need to have info on when the command line changed to make a "old mame" system. Anyone with this info?

razoba

  • Newbie
  • *
  • Posts: 3
    • Email
Re: illegal boolean value for sound reverting to 0
« Reply #4 on: October 17, 2019, 03:06:53 PM »
Ive downloaded 0.214 roms and mame latest version

All is good now

thanks