Author Topic: video preview slowness with premium themes  (Read 199 times)

justintomame

  • Newbie
  • *
  • Posts: 16
video preview slowness with premium themes
« on: March 30, 2019, 08:41:08 PM »
Not sure if anyone else has run into this issue, but when I'm using one of the premium themes like 'My vintage room one' or 'my arcade room one', the video previews are really slow to play and are jittery when they actually do play. They don't seem to play at all when using the 'my arcade room one' theme. However, if you switch to something like the 'Base' theme, all the issues go away.

Any idea what would be causing that with the premium themes if it's normal with the base one? I would really like to use the vintage one, but not if the preview videos don't play smoothly.

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 958
    • Email
Re: video preview slowness with premium themes
« Reply #1 on: March 31, 2019, 04:39:50 AM »
Are you by chance running mGalaxy on a "low end" PC? I'm afraid that it might be a 3D card performance issue!?
There's an "hidden" feature to display your FPS, enable it and report your FPS on 3D themes:
Open "C:\Users\'YourUserName'\AppData'\Roaming\mGalaxy\Preferences.xml" and edit
Code: [Select]
<advanced_showfps>false</advanced_showfps>
to
Code: [Select]
<advanced_showfps>true</advanced_showfps>
Note: the 'AppData' folder is hidden by default, you will have to allow Windows to display hidden files
« Last Edit: March 31, 2019, 04:41:21 AM by mgalaxy »

justintomame

  • Newbie
  • *
  • Posts: 16
Re: video preview slowness with premium themes
« Reply #2 on: March 31, 2019, 12:33:26 PM »
yeah, with that enabled you can see it start around 36 and then as soon as the theme finishes loading it drops down to 6.

The PC isn't bottom of the barrel though, so I figured the card would be able to run it. Kind of sucks if I have to buy an expensive card to use the themes given that other front ends are running on Raspberry PI's.

jmd

  • Full Member
  • ***
  • Posts: 141
    • Email
Re: video preview slowness with premium themes
« Reply #3 on: March 31, 2019, 12:54:11 PM »
6fps!? I'm running with a (very) cheap 3d card (around 50 bucks) and I'm getting about 100fps on every 3d themes!

Try to gain some FPS by changing the resolution (this can be achieved from the preferences window in mGalaxy), passing from 1080p to 720p for instance !?
« Last Edit: March 31, 2019, 01:25:36 PM by jmd »

justintomame

  • Newbie
  • *
  • Posts: 16
Re: video preview slowness with premium themes
« Reply #4 on: April 01, 2019, 07:10:26 AM »
okay, sounds like a good idea; I'll give that a shot.

Yeah, this is a new PC but one of the fanless, micro ones because I'm making a very small cabinet so you can bet that the graphics card is garbage in this one.

justintomame

  • Newbie
  • *
  • Posts: 16
Re: video preview slowness with premium themes
« Reply #5 on: April 01, 2019, 07:46:39 AM »
just tried forcing Windows and Mgalaxy down to 1024x768 and that did help a bit. The FPS is still really low, but with it at 12 the theme works better without the glitches.

As a side note, I did enable the FPS option on a VM I have running Windows, and this one is using the graphics card of my Mac (which is very good) and that one was only showing about 26 for that theme. Unless there are issues with it using the host OS graphics card.

I'll have to to see if there are any other ways to bring it up any more, but thanks a lot for the idea above. That helped.