Author Topic: weird crashing while browsing games with MAME  (Read 95 times)

Gianluca

  • Newbie
  • *
  • Posts: 10
weird crashing while browsing games with MAME
« on: November 06, 2017, 12:39:51 PM »
Hi,

I'm experiencing a weird problem with MAME system.

While browsing roms mGalaxy ALWAYS crashes in the middle of the P letter, It is not a rom-related problem since it crashes in two different places by going downward (Point Break) or upward (Prehistoric Isle). I tried to hide/make visible certain roms but  it looks that it doesn't make any difference, it may change the "place" of crashing but it is always in the same "area",.even switching from favorites/non favorites.

Everything's fine going backward from PO to A or forward from PR to Z.
Very weird.

I run on Windows 8.1 with MAMEUIfx175, I don't know if somewhere I can find a log file to post (Windows only pops up a mGalaxy shutdown window).

Any suggestion?

Than you in advance for your help!

Gianluca

Gianluca

  • Newbie
  • *
  • Posts: 10
Re: weird crashing while browsing games with MAME
« Reply #1 on: November 06, 2017, 01:06:43 PM »
/edit:

This is what I get from the Event Viewer:

Nome registro: Application
Origine:       Application Error
Data:          06/11/2017 18:41:44
ID evento:     1000
Categoria attivitą:(100)
Livello:       Errore
Parole chiave: Classico
Utente:        N/D
Computer:      Computer
Descrizione:
Nome dell'applicazione che ha generato l'errore: mGalaxy.exe, versione: 6.3.0.0, timestamp: 0x59a2f07b
Nome del modulo che ha generato l'errore: KERNELBASE.dll, versione: 6.3.9600.18666, timestamp: 0x58f32841
Codice eccezione: 0xe0434352
Offset errore 0x00015608
ID processo che ha generato l'errore: 0x7c4
Ora di avvio dell'applicazione che ha generato l'errore: 0x01d3572661988da1
Percorso dell'applicazione che ha generato l'errore: C:\Program Files (x86)\mGalaxy\mGalaxy.exe
Percorso del modulo che ha generato l'errore: C:\Windows\SYSTEM32\KERNELBASE.dll
ID segnalazione: c117f43d-c319-11e7-8898-001a7dda710f
Nome completo pacchetto che ha generato l'errore:
ID applicazione relativo al pacchetto che ha generato l'errore:
XML evento:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-11-06T17:41:44.000000000Z" />
    <EventRecordID>380706</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Computer</Computer>
    <Security />
  </System>
  <EventData>
    <Data>mGalaxy.exe</Data>
    <Data>6.3.0.0</Data>
    <Data>59a2f07b</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.3.9600.18666</Data>
    <Data>58f32841</Data>
    <Data>e0434352</Data>
    <Data>00015608</Data>
    <Data>7c4</Data>
    <Data>01d3572661988da1</Data>
    <Data>C:\Program Files (x86)\mGalaxy\mGalaxy.exe</Data>
    <Data>C:\Windows\SYSTEM32\KERNELBASE.dll</Data>
    <Data>c117f43d-c319-11e7-8898-001a7dda710f</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

I read another user had a similar problem with KERNELBASE.dll, however, i can normally run mGalaxy with database enabled except for the crash described in my previous post.

Gianluca

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 834
    • Email
Re: weird crashing while browsing games with MAME
« Reply #2 on: November 07, 2017, 03:39:54 AM »
It could be a problem while parsing the database!? Have you edited it by yourself?
Could you please send me a copy of the database so that I can check? (this file is called 'xmlout.xml', it is located in mGalaxy > Data > User Systems > 'The name of the system'

Gianluca

  • Newbie
  • *
  • Posts: 10
Re: weird crashing while browsing games with MAME
« Reply #3 on: November 07, 2017, 12:47:31 PM »
Yes, for sure, I'm just sending a zip file, thank you!

(Anyway, I didn't parse the xml file, just edited the database via mGalaxy after upgrading to Premium. Maybe a folder issue? BTW, all other systems work perfectly).

Gianluca

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 834
    • Email
Re: weird crashing while browsing games with MAME
« Reply #4 on: November 09, 2017, 04:34:08 AM »
Well! I've downloaded your xml file, created a MAME system and tested your DB file while browsing from "Point Blank" to "Prehistoric Island", then back...and everything is working as it should!



Maybe a corrupted image file!?

If you want to, try to isolate the time where the crash occurs, then send me an archive with the 'crashing' roms/snaps/mgalaxy folder (the whole thing)...so that I can test here!?

« Last Edit: November 09, 2017, 04:35:45 AM by mgalaxy »

Gianluca

  • Newbie
  • *
  • Posts: 10
Re: weird crashing while browsing games with MAME
« Reply #5 on: November 09, 2017, 12:47:53 PM »
Hi!

First of all, thank you very much for your effort in order to solve this problem.

Suggested by your gif animation, I did some checks and made an interesting discovery: the crashing is related to the Presenter theme., only with MAME and only with this theme. I tested all my other systems with Presenter and MAME itself with all other themes, and everything works fine.

Maybe this can put you on the right path to solution? I wonder if it's something involving the specific data used by the theme (game infos and logos)...

Best,
Gianluca

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 834
    • Email
Re: weird crashing while browsing games with MAME
« Reply #6 on: November 09, 2017, 01:05:40 PM »
I've ran a test with Presenter this time, browsing from a couple games before 'Point Blank' to a couple games after 'Prehistoric Island'....with success!

Can you please run those 2 tests:
1. [mGalaxy_Runway] Clear the path to all media (snap, covers, video, logo,..) for that system, save and run mGalaxy!
   > This is to check if there's a corrupted media that would make mGalaxy crash
2. [mGalaxy_Runway]  If it crashes again, could you uncheck 'Use script file' (available by clicking the 'Extra' button in the 'Systems' tab
    ...or simply rename your database to xmlou.xml.bak
   > This is to check if something got corrupted in the database (even if I've checked yours here...without any problem)

Gianluca

  • Newbie
  • *
  • Posts: 10
Re: weird crashing while browsing games with MAME
« Reply #7 on: November 09, 2017, 03:40:04 PM »
Solved!

It was due to a single, stupid corrupted file :) the Pop 'n' Flame logo was 0 Kb, as soon I deleted it everything worked back fine.

Thank you again for your assistance!

Gianluca

mgalaxy

  • Administrator
  • Hero Member
  • *****
  • Posts: 834
    • Email
Re: weird crashing while browsing games with MAME
« Reply #8 on: November 09, 2017, 04:21:47 PM »
Solved!

It was due to a single, stupid corrupted file :) the Pop 'n' Flame logo was 0 Kb, as soon I deleted it everything worked back fine.

Thank you again for your assistance!

Gianluca
Great! Is there any chance for you to send me this file? I would like to check it and write some code to prevent such errors in future updates!

Gianluca

  • Newbie
  • *
  • Posts: 10
Re: weird crashing while browsing games with MAME
« Reply #9 on: November 09, 2017, 05:06:07 PM »
Ouch!

I definitively deleted it without putting it in the trashbin. I should have thought about that... I'm very sorry!